Saltar para conteúdo


Foto
- - - - -

SMS com problemas de acentos e cedilhas


  • Por favor inicie sessão para responder
8 respostas a este tópico

#1 mariosp

mariosp

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • BQ E5 HD

Mensagem publicada 07 October 2014 - 13:49

Ao escrever uma SMS, se esta tiver um carácter especial (um acento ou uma cedilha, por ex.) o telefone ativa o Unicode e o limite máximo da SMS passa de 160 para 70 caracteres.Já andei a ver pelas opções e não encontro forma de desactivar o suporte a caracteres unicode. Se me distraio converte as sms em mms.

Já resolvi o problema da conversão automática passando os mms ao modo restrito, mas não consigo resolver o problema dos acentos e cedilhas.

Tentei o Big SMS, o Go SMS Pro, o Handcent SMS e nada...

Posso escrever sem acentos e cedilhas, vá... :(


Editado por mariosp, 07 October 2014 - 13:49.

  • zizasbento gosta disto

#2 Tec_Fil

Tec_Fil

    Guru de Android

  • Moderadores
  • 2485 mensagens
  • Localizaçãoaquele local a que chamam "casa"
  • Moto E 2015 --> Xiaomi Redmi 3

Mensagem publicada 07 October 2014 - 19:33

com o handcent sms e o pacote de linguagem Português não tenho esse problema num Aquaris 5.7


como já alguém muito sábio dizia: "windows for games, linux for real"

#3 mariosp

mariosp

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • BQ E5 HD

Mensagem publicada 07 October 2014 - 20:16

Pois, mas então pode ser um problema de configurações com o qual ainda não acertei. O facto é que quando uso um ç ou um ã numa sms come logo metade dos carateres disponíveis. Resultado: uma sms que parece normal em tamanho são 2 ou 3 e se não tivesse desativado o envio automático de mms lá se ia o plafon.

Alguma configuração em especial no Handcent?

Obrigado :)


Editado por mariosp, 07 October 2014 - 20:16.


#4 Qashqool

Qashqool

    Geek de Android

  • Membros
  • PipPipPipPip
  • 796 mensagens
  • Bq Aquaris A5 / A5 HD / E4.5

Mensagem publicada 08 October 2014 - 11:20

Podes instruir o handcent para não enviar caracteres especiais, (Definições/Configurações/Definições de mensagens enviadas/Portuguese SMS Mode/Enable) eu não gosto de usar, porque costumo escrever em bom português :), mas fica mais económico. E podes também optar por não autorizar a mudança para MMS nessa aplicação ( é a que uso) (Definições/Configurações/Definições de mensagens enviadas/Auto-converter para MMS (off) )


  • Rui Luís e mariosp gosta disto

Samsung S5830

Bq Aquaris 5; Bq Aquaris 5 HD; Bq Aquaris E4.5

 


#5 mariosp

mariosp

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • BQ E5 HD

Mensagem publicada 08 October 2014 - 11:25

Podes instruir o handcent para não enviar caracteres especiais, (Definições/Configurações/Definições de mensagens enviadas/Portuguese SMS Mode/Enable) (...)

 

Obrigado, já testei, era isto que me faltava. Tenho só de perceber o que aparece "do lado de lá", porque com essa opção aparece, no meu lado, o ç e o ã sem problemas :)



#6 Qashqool

Qashqool

    Geek de Android

  • Membros
  • PipPipPipPip
  • 796 mensagens
  • Bq Aquaris A5 / A5 HD / E4.5

Mensagem publicada 08 October 2014 - 14:59

sim, mas quem recebe não os tem :)


Samsung S5830

Bq Aquaris 5; Bq Aquaris 5 HD; Bq Aquaris E4.5

 


#7 mariosp

mariosp

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • BQ E5 HD

Mensagem publicada 08 October 2014 - 15:25

sim, mas quem recebe não os tem :)

Pois, já confirmei que os carateres especiais não são recebidos... a msg fica legivel, mas sem os ditos... só tendo do lado de lá a mesma aplicação de msg.

Ao que percebi este é um problema do Android e não apenas do meu BQ...



#8 Qashqool

Qashqool

    Geek de Android

  • Membros
  • PipPipPipPip
  • 796 mensagens
  • Bq Aquaris A5 / A5 HD / E4.5

Mensagem publicada 08 October 2014 - 16:40

Sim, acho que também do IOS


Samsung S5830

Bq Aquaris 5; Bq Aquaris 5 HD; Bq Aquaris E4.5

 


#9 mariosp

mariosp

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • BQ E5 HD

Mensagem publicada 08 October 2014 - 16:43

Sim, acho que também do IOS

Pois... quem ganha são as operadoras, oferecem sms e cobram mms...