Saltar para conteúdo


Foto
- - - - -

[PROBLEMA] Actualização para 4.4


  • Por favor inicie sessão para responder
13 respostas a este tópico

#1 ricdotnet

ricdotnet

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • Nexus 5

Mensagem publicada 23 June 2014 - 21:25

Boas, tenho um Samsung Galaxy S3 com 4.1.2 e queria actualizá-lo para 4.4..

Já flashei duas roms diferentes SuperNexus e NeatRom... Depois de actualizar fico com problema no IMEI, aparece desconhecido e quando tento enviar sms ou fazer uma chamada aperece "Rede desconhecida".

 

Não sei qual pode ser o problema... faço os passos todos como indicam lá no xda-developers mas nunca funciona correctamente.

 

Alguém que tenha tido este problema sabe como resolver?

 

cumps.


  • AustAdmilk gosta disto

#2 jmcdpereira

jmcdpereira

    Mestre de Android

  • Moderadores Globais
  • 9300 mensagens
  • LocalizaçãoAlentejo
  • Oneplus 2

Mensagem publicada 23 June 2014 - 21:31

e depois qd voltas para a 4.1.2 ficas com IMEI ?


y0gATWN.jpg
OnePlus 2

"Lavar a cabeça a burros é perder tempo e gastar sabão"


#3 ricdotnet

ricdotnet

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • Nexus 5

Mensagem publicada 23 June 2014 - 21:31

sim, quando dou restore fica tudo normal novamente.



#4 jmcdpereira

jmcdpereira

    Mestre de Android

  • Moderadores Globais
  • 9300 mensagens
  • LocalizaçãoAlentejo
  • Oneplus 2

Mensagem publicada 23 June 2014 - 21:33

sim, quando dou restore fica tudo normal novamente.

restore como ?

restore de um backup ?

Sem calhar eramelhor não arriscares mt e ficares sossegado... lol


  • Rui Luís gosta disto

y0gATWN.jpg
OnePlus 2

"Lavar a cabeça a burros é perder tempo e gastar sabão"


#5 ricdotnet

ricdotnet

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • Nexus 5

Mensagem publicada 23 June 2014 - 21:38

fiz um backup antes de fazer qualquer mexida no telemovel..

 

já experimentei essas roms e aparece sempre imei e rede desconhecida...

tambem vi ai que conseguiram utilizar a neatrom, então nao sei qual será problema....



#6 jmcdpereira

jmcdpereira

    Mestre de Android

  • Moderadores Globais
  • 9300 mensagens
  • LocalizaçãoAlentejo
  • Oneplus 2

Mensagem publicada 23 June 2014 - 21:42

fiz um backup antes de fazer qualquer mexida no telemovel..

 

já experimentei essas roms e aparece sempre imei e rede desconhecida...

tambem vi ai que conseguiram utilizar a neatrom, então nao sei qual será problema....

Pois é estranho sem duvida.

Como já não tenho o S3 não mando bitaites...


y0gATWN.jpg
OnePlus 2

"Lavar a cabeça a burros é perder tempo e gastar sabão"


#7 Nuno Ribeiro

Nuno Ribeiro

    Mestre de Android

  • Administradores
  • 3699 mensagens
  • LocalizaçãoMaia, Porto
  • Samsung Galaxy S9+ (SM-G965F/DS)

Mensagem publicada 24 June 2014 - 01:46

Provavelmente essa rom está baseada na novo modem que altera o caminho da partição da efs e por isso não encontra.
Penso que terias de flashar primeiro via Odin a 4.3 com esse novo modem (penso que é a MGA). No boot ele define a nova partição, depois instalar a recovery e só depois a rom 4.4.

Atenção que depois de teres a 4.3 (se voltares a colocar a 4.1.2 vais ter o mesmo problema mas agora na 4.1.2).

E claro, isto é só bitaites, também já não tenho o S3 há quase um ano...
  • Rui Luís gosta disto


PRESSIONA  ✔ GOSTO SE TE AJUDEI 

PRESS  ✔ LIKE THIS IF I HELPED YOU

Segue-nos também no Facebook e Google+

Consulta e respeita as regras do fórum


#8 jmcdpereira

jmcdpereira

    Mestre de Android

  • Moderadores Globais
  • 9300 mensagens
  • LocalizaçãoAlentejo
  • Oneplus 2

Mensagem publicada 24 June 2014 - 07:41

Provavelmente essa rom está baseada na novo modem que altera o caminho da partição da efs e por isso não encontra.
Penso que terias de flashar primeiro via Odin a 4.3 com esse novo modem (penso que é a MGA). No boot ele define a nova partição, depois instalar a recovery e só depois a rom 4.4.

Atenção que depois de teres a 4.3 (se voltares a colocar a 4.1.2 vais ter o mesmo problema mas agora na 4.1.2).

E claro, isto é só bitaites, também já não tenho o S3 há quase um ano...

Eu tb pensei nisso, mas a Neatrom não traz modem ?

Se tras modem muda a partição EFS e depois acho que nem com restore lá vai...

Seja ocmo for a ultima 4.2.1 já tem o modem MG4 com a nova partição EFS.

@ricdotnet

Já agora que ROM é essa 4.2.1 ?


y0gATWN.jpg
OnePlus 2

"Lavar a cabeça a burros é perder tempo e gastar sabão"


#9 ricdotnet

ricdotnet

    Novato

  • Membros
  • Pip
  • 5 mensagens
  • Nexus 5

Mensagem publicada 24 June 2014 - 09:20

Eu tb pensei nisso, mas a Neatrom não traz modem ?
Se tras modem muda a partição EFS e depois acho que nem com restore lá vai...
Seja ocmo for a ultima 4.2.1 já tem o modem MG4 com a nova partição EFS.
@ricdotnet
Já agora que ROM é essa 4.2.1 ?


Eu tenho a 4.1.2 que veio com o telemovel... Quando dou flash de uma 4.4 actualiza tudo correcto mas depois fica tudo unknown e apenas mostra a kernel e a versao do android.
Depois dou restore do backup original qe tenho e fixa tudo normal novamente...

O telemovel ja veio desbloqueado da loja. Sera por actualizar com o SIM inserido no tele?

Ate pode ser bug da rom, mas testei duas e as duas foi igual.

#10 jmcdpereira

jmcdpereira

    Mestre de Android

  • Moderadores Globais
  • 9300 mensagens
  • LocalizaçãoAlentejo
  • Oneplus 2

Mensagem publicada 24 June 2014 - 10:19

Eu tenho a 4.1.2 que veio com o telemovel... Quando dou flash de uma 4.4 actualiza tudo correcto mas depois fica tudo unknown e apenas mostra a kernel e a versao do android.
Depois dou restore do backup original qe tenho e fixa tudo normal novamente...

O telemovel ja veio desbloqueado da loja. Sera por actualizar com o SIM inserido no tele?

Ate pode ser bug da rom, mas testei duas e as duas foi igual.

Continuo a perguntar, que 4.2.1 tens instalado ?

Faz *#1234# e diz o que aparece


y0gATWN.jpg
OnePlus 2

"Lavar a cabeça a burros é perder tempo e gastar sabão"


#11 Nuno Ribeiro

Nuno Ribeiro

    Mestre de Android

  • Administradores
  • 3699 mensagens
  • LocalizaçãoMaia, Porto
  • Samsung Galaxy S9+ (SM-G965F/DS)

Mensagem publicada 24 June 2014 - 10:47

Eu tb pensei nisso, mas a Neatrom não traz modem ?
Se tras modem muda a partição EFS e depois acho que nem com restore lá vai...
Seja ocmo for a ultima 4.2.1 já tem o modem MG4 com a nova partição EFS.
@ricdotnet
Já agora que ROM é essa 4.2.1 ?

Se tivesse modem teria que ter a mais recente certo? E nesse caso nunca teria o IMEI quando voltou para o 4.1.2. Por isso ou não traz ou traz uma antiga...

Eu continuo a dizer que o melhor seria actualizar via Odin para a versão mais recente. Depois o melhor é fazer root e o backup da efs. Assim estaríamos seguros.

A partir daqui tentava-se flashar a 4.4. Primeiro backup via recovery, depois a nova, de algo correr mal faz-se restore.


PRESSIONA  ✔ GOSTO SE TE AJUDEI 

PRESS  ✔ LIKE THIS IF I HELPED YOU

Segue-nos também no Facebook e Google+

Consulta e respeita as regras do fórum


#12 Kyrex

Kyrex

    Membro

  • Membros
  • PipPip
  • 53 mensagens
  • LocalizaçãoLeiria
  • Samsung GT-I9300

Mensagem publicada 24 June 2014 - 22:42

Uma pergunta rapida, se eu fizer um backup ao efs, esse backup vai servir para sempre certo?



#13 jmcdpereira

jmcdpereira

    Mestre de Android

  • Moderadores Globais
  • 9300 mensagens
  • LocalizaçãoAlentejo
  • Oneplus 2

Mensagem publicada 25 June 2014 - 08:50

Uma pergunta rapida, se eu fizer um backup ao efs, esse backup vai servir para sempre certo?

Não necessáriamente.

Depende da ROM que tens neste momento.


  • Nuno Ribeiro gosta disto

y0gATWN.jpg
OnePlus 2

"Lavar a cabeça a burros é perder tempo e gastar sabão"


#14 Nuno Ribeiro

Nuno Ribeiro

    Mestre de Android

  • Administradores
  • 3699 mensagens
  • LocalizaçãoMaia, Porto
  • Samsung Galaxy S9+ (SM-G965F/DS)

Mensagem publicada 25 June 2014 - 09:46

O aconselhável é fazer-se backup sempre antes e depois de se flashar uma rom.
  • jmcdpereira gosta disto


PRESSIONA  ✔ GOSTO SE TE AJUDEI 

PRESS  ✔ LIKE THIS IF I HELPED YOU

Segue-nos também no Facebook e Google+

Consulta e respeita as regras do fórum