Saltar para conteúdo


Foto
* * * * * 1 votos

Instalar o Android SDK e estabelecer a ligaçao ADB e Fastboot em Windows e Windows 8


  • Por favor inicie sessão para responder
33 respostas a este tópico

#1 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 22 February 2013 - 22:26

Instalar o Android SDK e estabelecer a ligaçao ADB e Fastboot em Windows


Requisitos:
- Efectuar o download do Android SDK

Ficheiro anexado  SDKTools.png   90.99KB   271 descarregamentos

 

- Efectuar o download do driver adequado para o seu terminal (caso não seja um dos abaixo referidos)
-> Galaxy Nexus

-> Nexus 7 USB

Depois de efectuar o download do Android SDK e de ser instalado ou extraído para c:\android-sdk-windows ( vamos assumir a instalação nesta pasta ), abrimos uma linha de comando :

Ficheiro anexado  cmd.png   63.33KB   335 descarregamentos

e executamos os seguinte comandos :

- cd \android-sdk-windows
- "SDK Manager.exe"

Ficheiro anexado  Prompt.png   37.11KB   335 descarregamentos

para actualizar o Android SDK. É necessário instalar Android SDK Platform-tools.

Ficheiro anexado  AndroidSDK.png   68.44KB   362 descarregamentos

Depois de concluída a instalação é necessários adicionar o caminho ( Path ) para os utilitários adb e fastboot.
Se tentarmos executar o comando fastboot sem executarmos este passo, vamos obter uma mensagem de erro.
Na mesma linha de comando executamos o comando :

- sysdm.cpl

Ficheiro anexado  NoPathToFastboot.png   38.04KB   368 descarregamentos

Na tab Advanced, Enviroment Variables,

Ficheiro anexado  EnviromentVariables.png   39.25KB   314 descarregamentos

Escolhemos a variável Path e fazemos editamos.

Ficheiro anexado  EditPath.png   35.32KB   310 descarregamentos

Adicionamos o caminho ( Path ) : ;c:\android-sdk-windows\tools;c:\android-sdk-windows\platform-tools

Ficheiro anexado  AddPath.png   20.19KB   332 descarregamentos

Se abrirmos outra linha de comando e executarmos os comandos adb e fastboot, os mesmos já serão reconhecidos.

Ficheiro anexado  PathSetFastboot.png   47.1KB   312 descarregamentos

Depois de ligar o Galaxy Nexus ao PC via o cabo USB ainda nos falta fazer a instalação correcta dos drivers para o Galaxy Nexus.
Extraímos os drivers para a pasta c:\drivers e abrimos uma linha de comandos e executamos o comando :

- sysdm.cpl

Na tab Hardware, Device Manager

Ficheiro anexado  DeviceManager-Hardware.png   42.38KB   272 descarregamentos

procedemos à desinstalação do driver actual,

Ficheiro anexado  Uninstall.png   83.42KB   252 descarregamentos

eliminando o respectivo driver do sistema.

Ficheiro anexado  ConfirmUninstall.png   18.94KB   243 descarregamentos

Depois deste passo ( pode ser necessário efectuar reboot ), actualizamos para o driver correcto.

Ficheiro anexado  ExclamationGalaxyNexus.png   88.54KB   270 descarregamentos Ficheiro anexado  BrowserComputer.png   48.83KB   265 descarregamentos Ficheiro anexado  Drivers.png   44.11KB   249 descarregamentos Ficheiro anexado  InstallDriver.png   34.39KB   224 descarregamentos Ficheiro anexado  ADBInterface.png   43.05KB   233 descarregamentos

Se o telefone estiver a correr o sistema, no Device Manager irá aparecer o seguinte dispositivo :

Ficheiro anexado  GalaxyNexusADBInterface.png   73.46KB   248 descarregamentos

Se o telefone estiver em modo Fastboot, irá aparecer o seguinte dispositivo :

Ficheiro anexado  GalaxyNexusFastbootInterface.png   69.23KB   258 descarregamentos

Ao executar o comando :

- fastboot devices

irá aparecer a identificação do vosso GalaxyNexus.

Ficheiro anexado  FastbootDevices.png   30.08KB   217 descarregamentos

Fica assim concluído o processo de instalação do Android SDK e dos respectivos drivers que permitem o acesso ADB e Fastboot.

Agradecimento :



Ricardo Vieira pela correcção da Path.

Dark_Sorcerer pelo alerta em relação ao Android SDK.


Instalar o Android SDK e estabelecer a ligaçao ADB e Fastboot em Windows 8 por zznh

Como uma imagem vale mais do que mil palavras, aqui fica o conjunto de imagens partilhadas pelo zznh.

http://www.youtube.com/watch?v=hpOAjx9uzdg

Agradecimento :



zznh pela partilha.


Deixem feedback.

Um abraço.


Editado por Dark_Sorcerer, 03 May 2013 - 18:05.
Adicionado Universal Naked Driver (Galaxy Nexus)

  • babuja, Dark_Sorcerer, zedaale e 2 outros gostam disto

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#2 toinocalipo

toinocalipo

    Membro

  • Membros
  • PipPip
  • 53 mensagens
  • Nexus 7

Mensagem publicada 27 April 2013 - 19:32

Depois deste passo ( pode ser necessário efectuar reboot ), actualizamos para o driver correcto.

 

neste passo tou a ter problemas, deve ser porque nao fiz reboot, alguem me pode explicar o que fazer.

 

obrigado



#3 AbduL

AbduL

    Geek de Android

  • Membros
  • PipPipPipPip
  • 676 mensagens
  • LocalizaçãoOeiras

Mensagem publicada 03 May 2013 - 21:28

Certifica-te que desinstalas-te o driver. Começa do principio se for preciso.


Editado por AbduL, 03 May 2013 - 21:30.

  • Dark_Sorcerer gosta disto
if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
then mv $user.contact.up.post /.trash; set response($response.type ignore);
$user.up.post.ignore_in_future = true; fi;

 


#4 toinocalipo

toinocalipo

    Membro

  • Membros
  • PipPip
  • 53 mensagens
  • Nexus 7

Mensagem publicada 14 May 2013 - 11:43

Formatei o pc, não só mas também por não estar a conseguir instalar as drives correctamente.

 

Agora depois de fazer os passos todos até chegar a desinstalação da drive, no gestor de dispositivos, só tenho 2 opções: verificar se existem actualizações e propriedades.

 

Isto acontece tanto na drive do nexus como em todas as outras drives.

 

Alguém me consegue diser porque isto acontece e não tenho as opções normais que são referidas (desinstalr, instalr,...)?

 

Obrigado



#5 Dark_Sorcerer

Dark_Sorcerer

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 2767 mensagens
  • hammerhead

Mensagem publicada 14 May 2013 - 11:59

Boa tarde,

 

Podes colocar, por favor, um screenshot do teu "gestor de dispositivos"? Recordo-te também que podes aceder ao Google Talk do androidPT para te darmos uma ajuda.

 

Obrigado.

 

Um abraço,


Chat do fórum: http://l.androidpt.com/chat

#6 toinocalipo

toinocalipo

    Membro

  • Membros
  • PipPip
  • 53 mensagens
  • Nexus 7

Mensagem publicada 15 May 2013 - 09:34

Como faço para inserir uma imagem aqui no forum?

 

obrigado



#7 toinocalipo

toinocalipo

    Membro

  • Membros
  • PipPip
  • 53 mensagens
  • Nexus 7

Mensagem publicada 15 May 2013 - 10:00

Já consegui inserir imagem.

 

E são estas as opções que eu tenho, onde nem consigo desinstalar nem instalar as novas, alguma solução?

 

androidvn.jpg


Editado por toinocalipo, 15 May 2013 - 10:02.

  • TugaPower gosta disto

#8 Dark_Sorcerer

Dark_Sorcerer

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 2767 mensagens
  • hammerhead

Mensagem publicada 15 May 2013 - 10:57

Alo,

 

Presta bem atenção ao vídeo no segundo 0.09. Tens de abrir essa secção em que estás a carregar no segundo botão do rato.

 

Um abraço,


  • TugaPower gosta disto
Chat do fórum: http://l.androidpt.com/chat

#9 Dav7

Dav7

    Membro

  • Membros
  • PipPip
  • 124 mensagens
  • LocalizaçãoRibatejo
  • Nexus 5 e Galaxy Nexus

Mensagem publicada 20 July 2013 - 23:09

começo bem... vou para instalar as drives mas no meu gestor de dispositivos não aparece nada com o nome "Android device"



#10 Dark_Sorcerer

Dark_Sorcerer

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 2767 mensagens
  • hammerhead

Mensagem publicada 20 July 2013 - 23:44

começo bem... vou para instalar as drives mas no meu gestor de dispositivos não aparece nada com o nome "Android device"


Alo,

Pergunta parva: ligaste o telefone ao PC?

Segunda pergunta parva: não aparece um Galaxy Nexus também?

Um abraço,

Sent from my tilapia using Tapatalk HD
  • TugaPower gosta disto
Chat do fórum: http://l.androidpt.com/chat

#11 Dav7

Dav7

    Membro

  • Membros
  • PipPip
  • 124 mensagens
  • LocalizaçãoRibatejo
  • Nexus 5 e Galaxy Nexus

Mensagem publicada 21 July 2013 - 10:17

Alo,

Pergunta parva: ligaste o telefone ao PC?

Segunda pergunta parva: não aparece um Galaxy Nexus também?

Um abraço,

Sent from my tilapia using Tapatalk HD

primeiro fui ver sem ter ligado, depois liguei e continua a só aparecer isto:

 

idgb.jpg

mas tenho trocado ficheiro entre o PC e o Nexus sem problemas



#12 TugaPower

TugaPower

    Born in the Wild

  • Moderadores Globais
  • 6641 mensagens
  • LocalizaçãoMarseille, France
  • Samsung S6 Edge, OnePlus One, OnePlus 5

Mensagem publicada 21 July 2013 - 10:21

Porque tens os drivers de MTP instalados correctamente dai teres no gestor Dispositivos Portáteis.

Tens no Nexus o debug mode activo?

 

Definiçoes

Opções de programador

Depuraçao USB


Usem o "Gosto" nos posts para agradecer a quem vos ajuda.


#13 Dav7

Dav7

    Membro

  • Membros
  • PipPip
  • 124 mensagens
  • LocalizaçãoRibatejo
  • Nexus 5 e Galaxy Nexus

Mensagem publicada 21 July 2013 - 10:35

Porque tens os drivers de MTP instalados correctamente dai teres no gestor Dispositivos Portáteis.

Tens no Nexus o debug mode activo?

 

Definiçoes

Opções de programador

Depuraçao USB

Isso é outra coisa estranha, já ontem andei à procura e não encontrei:

 

xeu.png

mfx1.png

mc0k.png

 



#14 TugaPower

TugaPower

    Born in the Wild

  • Moderadores Globais
  • 6641 mensagens
  • LocalizaçãoMarseille, France
  • Samsung S6 Edge, OnePlus One, OnePlus 5

Mensagem publicada 21 July 2013 - 10:39

Vai a Acerca do Telefone, depois carrega muitas vezes seguidas em Numero da Compilação ate aparecer a mensagem que o menu foi activado, depois ja vais encontrar as Opções de programador ;)


  • Dav7 gosta disto

Usem o "Gosto" nos posts para agradecer a quem vos ajuda.


#15 Dav7

Dav7

    Membro

  • Membros
  • PipPip
  • 124 mensagens
  • LocalizaçãoRibatejo
  • Nexus 5 e Galaxy Nexus

Mensagem publicada 21 July 2013 - 10:44

Vai a Acerca do Telefone, depois carrega muitas vezes seguidas em Numero da Compilação ate aparecer a mensagem que o menu foi activado, depois ja vais encontrar as Opções de programador ;)

curioso, aprendi uma coisa nova l-o-l

 

então agora já aparece no Gestor de Dispositivos:

 

Dispositivos portáteis > Galaxy Nexus

 

Posso então avançar com o tutorial certo?


  • TugaPower gosta disto

#16 TugaPower

TugaPower

    Born in the Wild

  • Moderadores Globais
  • 6641 mensagens
  • LocalizaçãoMarseille, France
  • Samsung S6 Edge, OnePlus One, OnePlus 5

Mensagem publicada 21 July 2013 - 10:50

Penso que sim ;)


Usem o "Gosto" nos posts para agradecer a quem vos ajuda.


#17 Dav7

Dav7

    Membro

  • Membros
  • PipPip
  • 124 mensagens
  • LocalizaçãoRibatejo
  • Nexus 5 e Galaxy Nexus

Mensagem publicada 21 July 2013 - 11:02

Penso que sim ;)

já estava a seguir as dicas do video mas algo me faz confusão, eu vou as definições de arranque, reiniciou, F7 mas continuo com o Nexus ligado ao portátil o tempo todo? É que no vídeo aparece a imagem no "Gestor de Dispositivos" com o sinal de erro no Nexus mas no meu aparece como estando tudo instalado, acho que é porque quando o portátil reinicia ele volta a instalar tudo antes de eu o fazer manualmente!



#18 TugaPower

TugaPower

    Born in the Wild

  • Moderadores Globais
  • 6641 mensagens
  • LocalizaçãoMarseille, France
  • Samsung S6 Edge, OnePlus One, OnePlus 5

Mensagem publicada 21 July 2013 - 14:29

já estava a seguir as dicas do video mas algo me faz confusão, eu vou as definições de arranque, reiniciou, F7 mas continuo com o Nexus ligado ao portátil o tempo todo? É que no vídeo aparece a imagem no "Gestor de Dispositivos" com o sinal de erro no Nexus mas no meu aparece como estando tudo instalado, acho que é porque quando o portátil reinicia ele volta a instalar tudo antes de eu o fazer manualmente!


Afinal qual o problema?

Sent from my Nexus 7 using Tapatalk HD

Usem o "Gosto" nos posts para agradecer a quem vos ajuda.


#19 Dav7

Dav7

    Membro

  • Membros
  • PipPip
  • 124 mensagens
  • LocalizaçãoRibatejo
  • Nexus 5 e Galaxy Nexus

Mensagem publicada 21 July 2013 - 14:32

podes ir ao chat aqui do fórum? Para não estar a encher este tópico com as minhas dúvidas :|



#20 TugaPower

TugaPower

    Born in the Wild

  • Moderadores Globais
  • 6641 mensagens
  • LocalizaçãoMarseille, France
  • Samsung S6 Edge, OnePlus One, OnePlus 5

Mensagem publicada 21 July 2013 - 14:37

podes ir ao chat aqui do fórum? Para não estar a encher este tópico com as minhas dúvidas :|

 

Ja la estou ...


Usem o "Gosto" nos posts para agradecer a quem vos ajuda.


#21 ppdneto

ppdneto

    Novato

  • Membros
  • Pip
  • 1 mensagens
  • Galaxy Nexus

Mensagem publicada 21 July 2013 - 15:38

Olá. Acho interessante continuar a resolver essa dúvida por aqui.

É um problema comum (eu estou com o mesmo)...

O que acham?



#22 josebarao

josebarao

    Membro

  • Membros
  • PipPip
  • 11 mensagens
  • LocalizaçãoLisboa
  • Nexus 5, HTC Google Nexus 9

Mensagem publicada 14 August 2013 - 11:34

Uns erros que surgiram ao executar este processo.

 

- o comando "sysdm.cpl" a partir do momento que alterei o path deixou de ser executado e aparece como um erro;

 

- e na instalação do driver o dispositivo que apareceu em vez de "Android Device" foi "Samsung Android Device";

 

Mas apesar de tudo isto consegui executar o procedimento. Muito obrigado pela ajuda.



#23 marcosdft

marcosdft

    Novato

  • Membros
  • Pip
  • 3 mensagens
  • Galaxy Nexus i9250, Sony Erickson xperia mini

Mensagem publicada 23 October 2013 - 22:36

Não estou a conseguir que o meu Nexus seja detetado através do comando "fastboot devices".

Aparentemente tenho tudo instalado, SDK, drivers, configuração das variáveis e o modo debug ativo.

 

Alguma ideia?

Obrigado



#24 AbduL

AbduL

    Geek de Android

  • Membros
  • PipPipPipPip
  • 676 mensagens
  • LocalizaçãoOeiras

Mensagem publicada 24 October 2013 - 01:20

Colocas-te o tlm em modo fastboot?
  • TugaPower gosta disto
if [ $up.post.type = $type.two.lazy.to_use_google ] || [ $up.post.type = $type.silly_question ];
then mv $user.contact.up.post /.trash; set response($response.type ignore);
$user.up.post.ignore_in_future = true; fi;

 


#25 marcosdft

marcosdft

    Novato

  • Membros
  • Pip
  • 3 mensagens
  • Galaxy Nexus i9250, Sony Erickson xperia mini

Mensagem publicada 24 October 2013 - 14:31

Era o que faltava. Agora sei que está OK, vou continuar com o processo.

 

Obrigado


  • TugaPower gosta disto