Saltar para conteúdo


Foto
- - - - -

Efectuar e receber chamadas com o Nexus 7 3G


  • Por favor inicie sessão para responder
22 respostas a este tópico

#1 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 02 February 2013 - 16:36

Efectuar e receber chamadas de voz com o Nexus 7 3G

Requisitos:

- Conta SIP ( Sapo ou outra. No meu caso uso o Sapo )
- CSipSimple
- framework-res.apk modificado - A disponibilizar ou como alternativa usar a rom ONE.PT.Tilapia. Com a rom ONE.PT.Tilapia também é possível enviar e receber MMS/SMS.

Ficheiros ( estes ficheiros não são necessários para a rom ONE.PT.Tilapia ):

Android 4.2.1:
- framework-res.apk ( voice capable )
- framework-res.apk ( original )

Android 4.2.2:
- framework-res.apk ( voice capable )
- framework-res.apk ( original )

Com esta configuração é possível efectuar chamadas de voz para números fixos e números móveis.
Também é possível receber chamadas.
No caso da Sapo é possível efectuar, de forma gratuita, chamadas para os números começados por 2 e 3 e a €0,23 por minuto para as redes móveis. Para mais informações, consultar o tarifário Sapo.

Reunidos os requisitos e depois da instalação do CSipSimple basta configurar a respectiva aplicação com os dados da conta Sapo ( ou outra, das muitas suportadas ).
De seguida é só desfrutar das chamadas por voz.

Espero que este pequeno post vós seja útil.
Deixem feedback.

Um abraço.

Editado por on.one, 18 February 2013 - 23:17.

  • Hugo Tender, Dark_Sorcerer, fylypynho e 1 outro gosta disto

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#2 Hugo Tender

Hugo Tender

    Mestre de Android

  • Administradores
  • 3481 mensagens
  • LocalizaçãoPortugal
  • Motorola Nexus 6 - Midnight Blue - 32GB - 5.1 e Samsung Galaxy Tab S 8.4 (T700) - 16GB - 4.4.2

Mensagem publicada 04 February 2013 - 09:21

Boas.

Desde já, quero agradecer o grande contributo que tens prestado na desenvolvimento deste tablet! ;)

Pelo que percebi e, para ficar esclarecido, para quem tem a tua ROM, basta instalar a aplicação CSipSimple?

Abraço, Tender

#3 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 04 February 2013 - 09:54

Boas.

Desde já, quero agradecer o grande contributo que tens prestado na desenvolvimento deste tablet! ;)

Pelo que percebi e, para ficar esclarecido, para quem tem a tua ROM, basta instalar a aplicação CSipSimple?

Abraço, Tender

Bom dia,

Correcto! A rom ONE.PT já tem tudo o que é necessário.

Um abraço.
  • Hugo Tender gosta disto

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#4 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 08 February 2013 - 20:44

Estou a usar o root explorer para tentar substituir a framework mas não estou a conseguir por causa das permissões.. Alguma dica? Obrigado

#5 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 08 February 2013 - 20:51

Estou a usar o root explorer para tentar substituir a framework mas não estou a conseguir por causa das permissões.. Alguma dica? Obrigado

Boa noite,

Necessitas de ter root para colocar o filesystem /system em modo rw.

Um abraço.

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#6 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 09 February 2013 - 22:37

Boa noite,

Necessitas de ter root para colocar o filesystem /system em modo rw.

Um abraço.


Já consegui fazer isso e quando mudei o framework tive problemas de boot loop... Que programa usam para descompilar a framework? é que os que tenho usado têm dado sempre erros.

Obrigado

#7 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 09 February 2013 - 22:47

Já consegui fazer isso e quando mudei o framework tive problemas de boot loop... Que programa usam para descompilar a framework? é que os que tenho usado têm dado sempre erros.

Obrigado

Boa noite,

Chegaste a fazer wipe à cache e dalvik-cache?
Se tiveres CWM aplica o ficheiro por esse método.
Eu faço o decompile dos apk's com o apktool.

Um abraço.

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#8 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 09 February 2013 - 22:56

Boa noite,

Chegaste a fazer wipe à cache e dalvik-cache?
Se tiveres CWM aplica o ficheiro por esse método.
Eu faço o decompile dos apk's com o apktool.

Um abraço.


Não fiz wipe porque estou com a rom de origem e não tenho o CWM instalado mas secalhar vou instalar porque dá sempre jeito.

Podes colocar um link para o Apktool? Não sei se estarei a usar a versão certa.. porque sempre que faço decompile apenas fica uma pasta com o nome da framework mas esta vazia.. sem ficheiro nenhum..

Obrigado

#9 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 09 February 2013 - 23:03

Não fiz wipe porque estou com a rom de origem e não tenho o CWM instalado mas secalhar vou instalar porque dá sempre jeito.

Podes colocar um link para o Apktool? Não sei se estarei a usar a versão certa.. porque sempre que faço decompile apenas fica uma pasta com o nome da framework mas esta vazia.. sem ficheiro nenhum..

Obrigado

Boa noite,

Tenta usar esta versão.
Deixa feedback.

Um abraço.

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#10 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 09 February 2013 - 23:24

Boa noite,

Tenta usar esta versão.
Deixa feedback.

Um abraço.


Já funciona esta versão.. Estava complicado.. já tinha experimentado umas 20 versões diferentes e nenhuma delas funciona.. Vou então tentar mudar a framework e depois compilar de novo.

Uso o CWM para substutuir a framewokr e depois faço wipe as caches?

Obrigado

#11 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 10 February 2013 - 08:52

Já funciona esta versão.. Estava complicado.. já tinha experimentado umas 20 versões diferentes e nenhuma delas funciona.. Vou então tentar mudar a framework e depois compilar de novo.

Uso o CWM para substutuir a framewokr e depois faço wipe as caches?

Obrigado

Bom dia,

Se usares o ficheiro que disponibilizei, ao instalares na CWM, substitui o framework-res.apk e apagar a cache e dalvik-cache.

Um abraço.

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#12 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 10 February 2013 - 14:16

Bom dia,

Se usares o ficheiro que disponibilizei, ao instalares na CWM, substitui o framework-res.apk e apagar a cache e dalvik-cache.

Um abraço.


Usei a framework que disponibilizaste e funcionou perfeitamente..

Obrigado

#13 Rkc85

Rkc85

    Membro

  • Membros
  • PipPip
  • 133 mensagens

Mensagem publicada 10 February 2013 - 23:33

Criei uma conta sapo. Da me sempre erro na coneccao

Sent from my Nexus 7 3G using Tapatalk 2



#14 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 11 February 2013 - 08:31

Criei uma conta sapo. Da me sempre erro na coneccao

Sent from my Nexus 7 3G using Tapatalk 2

Bom dia,

Criaste um conta VoIP Sapo ou apenas criaste uma conta Sapo?
Depois de teres criado uma conta VoIP sapo deverás ter um número de telefone começado por 302xxxxxx.
A única coisa necessária a configurar o CSipSimple é esse número antecedido de +351 e a tua password.
Deixa feedback.

Um abraço.

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#15 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 16 February 2013 - 01:46

Boa noite.. Actualizei agora para o 4.2.2 e depois de tentar aplicar novamente esta outra framework deu erro e entra em bootloop. A framework passa a ser outra por estar a usar o 4.2.2? Obrigado

#16 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 16 February 2013 - 10:13

Boa noite.. Actualizei agora para o 4.2.2 e depois de tentar aplicar novamente esta outra framework deu erro e entra em bootloop. A framework passa a ser outra por estar a usar o 4.2.2? Obrigado

Bom dia,

Sim, vai ser necessário produzir outro framework com a alteração necessária.
Logo que tenha tempo disponível trato disso.
Obrigado,

Um abraço.
  • xtype gosta disto

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#17 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 16 February 2013 - 16:38

Bom dia,

Sim, vai ser necessário produzir outro framework com a alteração necessária.
Logo que tenha tempo disponível trato disso.
Obrigado,

Um abraço.


Muito obrigado pela ajuda...

Abraço

#18 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 18 February 2013 - 23:18

Boa noite,

Tópico actualizado para a versão android 4.2.2.
Deixem feedback,

Um abraço.

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#19 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 18 February 2013 - 23:36

Boa noite,

Não sei se é de interesse mas hoje testei outra opção de chamadas por voz usando o Viber.
Na rom stock com o recurso à aplicação GoSMS e à aplicação Viber ( não disponível na Playstore para o Nexus 7 ). A instalação pode ser efectuada com:

- adb install com.viber.voip-1.apk

A aplicação GoSMS apenas é necessária para receber a SMS com o código de activação.
Na rom ONE.PT a aplicação GoSMS não é necessária.

Depois da recepção do código de activação, o Viber fica pronto a usar.
Deixem feedback,

Um abraço.
  • Dark_Sorcerer gosta disto

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#20 Dark_Sorcerer

Dark_Sorcerer

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 2765 mensagens
  • hammerhead

Mensagem publicada 19 February 2013 - 12:02

Alo on.one,

O único problema do Viber é que é um sorvedouro de bateria. Pelo menos, comigo sempre foi no GNexus. Mas é uma solução válida, claramente.

Um abraço,
Chat do fórum: http://l.androidpt.com/chat

#21 xtype

xtype

    Membro

  • Membros
  • PipPip
  • 24 mensagens

Mensagem publicada 21 February 2013 - 19:16

Estou a tentar fazer a alteração da framework e compilação e estou sempre a ter erros na compilação.. Estou a usar o apktool e da-me sempre erro. Alguma ideia do que possa ser? Obrigado

#22 on.one

on.one

    Mestre de Android

  • Former Staff
  • PipPipPipPipPipPip
  • 5169 mensagens
  • LocalizaçãoAlfragide

Mensagem publicada 21 February 2013 - 20:02

Estou a tentar fazer a alteração da framework e compilação e estou sempre a ter erros na compilação.. Estou a usar o apktool e da-me sempre erro. Alguma ideia do que possa ser? Obrigado

Boa noite,

Confirma a versão do apktool que estás a usar. Há o link acima para o apktool actualizado.

Um abraço.

Nexus 6 - Stock Android 6.0.1 (MMB29K), no userdata encription, display @ 1080p.


#23 fedakim

fedakim

    Novato

  • Membros
  • Pip
  • 7 mensagens

Mensagem publicada 18 June 2013 - 11:30

Experimentem usar esta app

 

https://play.google....tanvoxphonefree

 

É um softphone feito por tugas ;) E funciona no Nexus sem mexer em nada.

 

Até suporta Video.


  • Ricardo Martinho gosta disto